Acrobat Reader (acroread) už nelze nainstalovat?!

Problémy s programy či vše s tím související.

Acrobat Reader (acroread) už nelze nainstalovat?!

Příspěvekod Kebab » ned 10. led 2016 10:21:53

Loni někdy koncem léta (2015) a když jsem poprvé zkoušel Manjaro nebyl s instalací acroread (z AUR) u mne problém. Tak jsem to s uspokojením dal stranou a že není co dál řešit. Mezi tím tj. k dnešku jsem ale provedl novou instalaci Manjaro.
A protože věc se stala už akutní, viz interaktivní tiskopis české Finanční správy ve formátu PDF 25 5405 vzor 22 pro přiznání daně z příjmu FO za zdaňovací období roku 2015
http://www.financnisprava.cz/cs/danove- ... -tiskopisu
tak jsem se pokusil acroread doinstalovat. Ovšem a po několika pokusech marně: instalace pro mne končí nekonečnou (tedy bez časového omezení) hláškou ve smyslu že Pacman pracuje ... ale nedopracuje se konce.
Než jsem položil zde hlášku a jako také dotaz, snažil jsem se věc vygooglit, ovšem postup dle návodů končil vždy stejně, tj. již jsem nemohl stáhnout soubor acroread.tar.gz a případně jsem končil na webu Adobe s tím poznáním, že Adobe v tabulce výběru operačních systémů (ke stažení instalací) Linux již vůbec nezná.

Osobně jsem si tento problém vyřešil tak, že interaktivní tiskopis PDF jsem vyplnil v distribuci Mint a kde je acroead (zatím?) dostupný, další zálohu jsem měl ve W7 co mám "pro všechny případy" když bude nejhůř. Ovšem to není dostupné pro každého a je to svým způsobem i pro Manjaro (Arch) jako kapitulace.
Častá odpověď, že na vině je prý Finanční správa případně další úřady a tím že vnucují PDF, není řešením to když pod Linuxem je nutné ten tiskopis opravdu už vyplnit a není zbytí: nejde totiž o určení viny ale jak to vyřešit.
Vyplnění těchto tiskopisů ručně tj. do staženého a vytištěného neinteraktivního PDF také není řešením: právě proto, že interaktivní forma provádí matematické výpočty a především také kontroly a i ty logické.
Kebab
 
Příspěvky: 29
Registrován: pon 09. lis 2015 15:18:58

Re: Acrobat Reader (acroread) už nelze nainstalovat?!

Příspěvekod 80Sus » ned 10. led 2016 15:26:11

Nedalo mi to a zkusil jsem arcoread z yaourtu nainstalovat.
Žádný problém jsem během instalace neměl a vše proběhlo během 5ti minut.
Netuším, kde by tedy mohla být chyba.

Výpis "uname -a":
Kód: Vybrat vše
4.1.15-1-MANJARO #1 SMP PREEMPT Tue Dec 15 07:48:44 UTC 2015 x86_64 GNU/Linux

To, že Adobe ukončil podporu pro linux je pěkná podpásovka :/
Pokud potřebné funkce nejsou dostupné ani v okularu, evince nebo pdfview, asi by byla ještě možnost nainstalovat Adobe Reader přes WINE.
.
80Sus
 
Příspěvky: 27
Registrován: pát 08. lis 2013 22:38:50

Re: Acrobat Reader (acroread) už nelze nainstalovat?!

Příspěvekod Kebab » ned 10. led 2016 16:52:01

Já to instaloval přes klikátko Pamac, tehdy když to bylo loni ještě úspěšné tak záležitost asi když ne těch 5 tak 10 minut.
Teď to začne viset a jak popisuji třeba 1 a 1/2 hodiny s hláškou: "Pacman je teď používán, prosím počkejte." a tím to celé končí. Tedy je to viditelný nesmysl.
No tak vím, že jsi to nainstaloval alespoň ty a jako motivaci hledat jak dál :D
Jo, právě jsme odzkoušel yaourt se stejným výsledkem tedy nevýsledkem.
Kebab
 
Příspěvky: 29
Registrován: pon 09. lis 2015 15:18:58

Re: Acrobat Reader (acroread) už nelze nainstalovat?!

Příspěvekod Kebab » ned 10. led 2016 17:30:23

VYŘEŠENO - ještě jednou dík za ubezpečení, že jsi to u sebe nainstaloval. Podezření padlo na "věci" kolem repozitářů a provedl jsem přes Pacman novou synchronizaci databází. Ač si nejsem vědom ničeho závadného před tím. Žádných chybových hlášek a ani při instalaci toho acroread. Potom instalace proběhla tak jak má.
Kebab
 
Příspěvky: 29
Registrován: pon 09. lis 2015 15:18:58

Re: Acrobat Reader (acroread) už nelze nainstalovat?!

Příspěvekod 80Sus » ned 10. led 2016 21:52:09

Jsem rád, že se povedlo.

Často, když mi něco v pacmanu nejede tak jak má, používám kombinaci:
Kód: Vybrat vše
sudo rm -f /var/lib/pacman/db.lck && sudo pacman-mirrors -g && sudo pacman -Syyuu  && sudo pacman -Suu

Většinou to pomůže.
80Sus
 
Příspěvky: 27
Registrován: pát 08. lis 2013 22:38:50

Re: Acrobat Reader (acroread) už nelze nainstalovat?!

Příspěvekod Kebab » sob 11. čer 2016 19:37:01

Teď po posledním povýšení Manjaro přestal být zcela funkční Acrobat Reader 9 (acroread), řešení je:
sudo pacman -U http://repo.manjaro.org.uk/pool/sync/li ... pkg.tar.xz
a dle tohoto odkazu:
https://forum.manjaro.org/t/acroread-do ... ate/3389/6

Krátce před tím (asi 1 až 2 měsíce?) jsem však stejně zaznamenal sníženou stabilitu, program při prohlížení rozsáhlejších souborů PDF začal překvapivě samovolně padat a což, žel, přetrvává po znovu zprovoznění a dle řešení výše - a je to proto na vztek. Výhledově asi na odpis. Protože 9 je stejně už stará verze.
Připomínám, že smysl programu je v tom že některé interaktivní formuláře a třeba od státní správy nebo zdravotní pojišťovny jsou/mohou být řešitelné jen tímto způsobem! Na běžné prohlížení atp. postačuje pochopitelně nabídka programů z pod Linuxu. Ale onu funkčnost interaktivního formuláře nemají. Takže jedině doufat, že při případném vyplňování 1 nebo 2 stránek formuláře program nespadne?! Mrzuté.

Pokoušel jsem se zprovoznit žádoucně novější Acrobat Reader 11 a pod Wine:
https://appdb.winehq.org/objectManager. ... ngId=92286
ale nebyl jsem úspěšný. Zatím jsem s Wine totiž nedělal a návod už v detailech se zdá být starší tudíž jsem i improvizoval. Nainstaloval jsem, ovšem program byl nefunkční. Soubor PDF jsem neotevřel.

Dodatečná poznámka dne 18.07. 2016 - POZOR na datum ukončení nabídky:
Ukončení nabídky bezplatného upgrade na Windows 10. Která má vypršet prý už teď koncem července 2016 (tedy asi za 10 dní) a pokud nedojde k prodloužení. I když jsem za Windows chtěl a už s konečnou platností spálit mosty, tak na tomto příkladu "acroread" jsem se přesvědčil že to je a i do budoucna bude velmi rizikové: ponechal jsem si tímto způsobem vrátka proto otevřená. Tj. Windows 10 a s tzv. digitálním nárokem (zdarma a také legitimně) jsem nainstaloval jako dual-boot. Pro tento a podobné případy.
Kebab
 
Příspěvky: 29
Registrován: pon 09. lis 2015 15:18:58

Re: Adobe Acrobat Reader DC skrze PlayOnLinux

Příspěvekod Kebab » pon 28. lis 2016 11:29:49

jde již nainstalovat.
Na pokusných vzorcích (pod Xfce a KDE) se jeví program stabilně. Na rozdíl od padající přímé instalace balíčku pro acroread. Také jsem bez problémů a na zkoušku jednu stránku otevřeného souboru PDF vytiskl.
Tím optimismus ale končí. Formulář (příkladem právě onen známý roční výkaz pro VZP) nelze vyplnit česky. Tudíž nepoužitelné a právě pro potřeby případného vyplňování formulářů. Co si vzpomenou české úřady a kde potom k Adobe není pro Linux náhrada!
K náhle vynořivší se komplikaci s psaním ď ť ň atp. v LibreOffice a v dalších některých programech pod KDE a LXQT (viz moje hláška jinde zde na fóru) je toto další rána pod český pás.
Už nemíním trávit další dlouhé hodiny s hledáním úpravy nějakých lokale a převážně zoufalou metodou pokus omyl. Musím to a žel napsat: pro systém, který nemám tzv. na hraní a na experimenty ale pro práci, jsem ty hodiny raději už věnoval ... nové instalaci posledního OpenSUSE Leap 42.2, také s a dá se napsat právě posledním KDE Plasma 5.8.3, ovšem s tím že tady česky zatím bez problémů v tom LibreOffice a i v Adobe píšu.
Kebab
 
Příspěvky: 29
Registrován: pon 09. lis 2015 15:18:58


Zpět na Software

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 1 návštěvník

cron